Supported Platforms & System Requirements

This article contains information on the platforms that are officially supported by TempWorks Software® along with system requirements, broken down by product.

*Note* Supported platforms and system requirements for all TempWorks products are subject to change.

Overall

  • Beta releases of browsers and/or devices are NOT officially supported.
  • Once Microsoft has stopped supporting Internet Explorer, or the browser version can no longer handle our requirements, Internet Explorer will no longer be supported by TempWorks products.
  • As of January 14th, 2020, Microsoft will no longer be supporting Windows 7. This means that while TempWorks products may continue to work on Windows 7 machines, it is not guaranteed, and it is highly encouraged that you upgrade to Windows 10. This will ensure you have all of the latest security updates. For more information from Microsoft, please see the following article.

Beyond™

  • Chrome, Firefox, Safari – Latest two major versions
  • Edge - Only the latest major version

Bridge™

  • Chrome, Firefox, Safari - Latest two major versions
  • Internet Explorer and Edge - Only the latest major version

Buzz™

  • iOS 11 up to and including the latest version of the operating system
  • Android 4.1 up to and including the latest version of the operating system

Core™

  • System requirements can be found here.
  • Remote application requirements can be found here.

Enterprise™

  • System requirements can be found here.
  • Remote application requirements can be found here.

HRCenter™

  • Chrome, Firefox, Safari, and Edge – Latest two major versions
  • Internet Explorer - Only the latest major version

Job Board™

  • Chrome, Firefox, Safari - Latest two major versions
  • Internet Explorer and Edge - Only the latest major version

WebCenter™

  • Chrome, Firefox, Safari - Latest two major versions
  • Internet Explorer and Edge - Only the latest major version

Related Articles

  • None